Skip to main content
← All vulnerabilities
CVE-2023-31098GHSA-W3WR-GMWF-R333

Apache InLong: Weak Password Implementation in InLong

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.47.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Weak Password Requirements vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.1.0 through 1.6.0.  When users change their password to a simple password (with any character or symbol), attackers can easily guess the user's password and access the account. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7805 https://github.com/apache/inlong/pull/7805 to solve it.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache InLong

    From 1.1.0 · through 1.6.0

  • org.apache.inlong:manager-pojoMaven

    From 1.1.0 · fixed in 1.47.0

References 1

lists.apache.org