Skip to main content
← All vulnerabilities
CVE-2023-31065GHSA-757P-7HP5-PQMR

Apache InLong: Insufficient Session Expiration in InLong

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.7.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Insufficient Session Expiration vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.6.0.  An old session can be used by an attacker even after the user has been deleted or the password has been changed. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 , https://github.com/apache/inlong/pull/7884 https://github.com/apache/inlong/pull/7884 to solve it.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache InLong

    From 1.4.0 · through 1.6.0

  • org.apache.inlong:manager-pojoMaven

    From 1.4.0 · fixed in 1.7.0

  • org.apache.inlong:manager-daoMaven

    From 1.4.0 · fixed in 1.7.0

  • org.apache.inlong:manager-webMaven

    From 1.4.0 · fixed in 1.7.0

  • org.apache.inlong:manager-serviceMaven

    From 1.4.0 · fixed in 1.7.0

References 1

lists.apache.org