Skip to main content
← All vulnerabilities
CVE-2023-31007GHSA-47R2-PHR8-M8CP

Apache Pulsar: Broker does not always disconnect client when authentication data expires

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.9.5, 2.10.4, 2.11.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Improper Authentication vulnerability in Apache Software Foundation Apache Pulsar Broker allows a client to stay connected to a broker after authentication data expires if the client connected through the Pulsar Proxy when the broker is configured with authenticateOriginalAuthData=false or if a client connects directly to a broker with a specially crafted connect command when the broker is configured with authenticateOriginalAuthData=false. This issue affects Apache Pulsar: through 2.9.4, from 2.10.0 through 2.10.3, 2.11.0. 2.9 Pulsar Broker users should upgrade to at least 2.9.5. 2.10 Pulsar Broker users should upgrade to at least 2.10.4. 2.11 Pulsar Broker users should upgrade to at least 2.11.1. 3.0 Pulsar Broker users are unaffected. Any users running the Pulsar Broker for 2.8.* and earlier should upgrade to one of the above patched versions.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Pulsar

    fixed in 2.9.5; From 2.10.0 · through 2.10.3

  • org.apache.pulsar:pulsar-brokerMaven

    From 2.9.0 · fixed in 2.10.4

  • org.apache.pulsar:pulsar-brokerMaven

    From 2.11.0 · fixed in 2.11.1

References 1

lists.apache.org