Skip to main content
← All vulnerabilities
CVE-2023-30838GHSA-FH7R-996Q-GVCP

PrestaShop vulnerable to possible XSS injection through Validate::isCleanHTML method

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.0.4, 1.7.8.9
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

PrestaShop is an Open Source e-commerce web application. Prior to versions 8.0.4 and 1.7.8.9, the `ValidateCore::isCleanHTML()` method of Prestashop misses hijackable events which can lead to cross-site scripting (XSS) injection, allowed by the presence of pre-setup `@keyframes` methods. This XSS, which hijacks HTML attributes, can be triggered without any interaction by the visitor/administrator, which makes it as dangerous as a trivial XSS attack. Contrary to other attacks which target HTML attributes and are triggered without user interaction (such as onload / onerror which suffer from a very limited scope), this one can hijack every HTML element, which increases the danger due to a complete HTML elements scope. Versions 8.0.4 and 1.7.8.9 contain a fix for this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • PrestaShop PrestaShop

    From 8.0.0 · fixed in 8.0.4; fixed in 1.7.8.9

  • prestashop/prestashopPackagist

    From 8.0.0 · fixed in 8.0.4

  • prestashop/prestashopPackagist

    fixed in 1.7.8.9

References 3

GitHub · PrestaShop/PrestaShop