Skip to main content
← All vulnerabilities
CVE-2023-30428GHSA-J2R7-3RVW-G7GX

Apache Pulsar Broker: Incorrect Authorization Validation for Rest Producer

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.10.4, 2.11.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar Broker's Rest Producer allows authenticated user with a custom HTTP header to produce a message to any topic using the broker's admin role. This issue affects Apache Pulsar Brokers: from 2.9.0 through 2.9.5, from 2.10.0 before 2.10.4, 2.11.0. The vulnerability is exploitable when an attacker can connect directly to the Pulsar Broker. If an attacker is connecting through the Pulsar Proxy, there is no known way to exploit this authorization vulnerability. There are two known risks for affected users. First, an attacker could produce garbage messages to any topic in the cluster. Second, an attacker could produce messages to the topic level policies topic for other tenants and influence topic settings that could lead to exfiltration and/or deletion of messages for other tenants. 2.8 Pulsar Broker users and earlier are unaffected. 2.9 Pulsar Broker users should upgrade to one of the patched versions. 2.10 Pulsar Broker users should upgrade to at least 2.10.4. 2.11 Pulsar Broker users should upgrade to at least 2.11.1. 3.0 Pulsar Broker users are unaffected.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Pulsar Broker

    From 2.9.0 · through 2.9.5; From 2.10.0 · fixed in 2.10.4

  • org.apache.pulsar:pulsar-brokerMaven

    From 2.9.0 · fixed in 2.10.4

  • org.apache.pulsar:pulsar-brokerMaven

    From 2.11.0 · fixed in 2.11.1

References 1

lists.apache.org