Skip to main content
← All vulnerabilities
CVE-2023-29234GHSA-6X49-W35H-WQRJ

Bypass serialize checks in Apache Dubbo

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.1.11, 3.2.5
None on Exploit-DB, Metasploit or GitHub

Summary

A deserialization vulnerability existed when decode a malicious package.This issue affects Apache Dubbo: from 3.1.0 through 3.1.10, from 3.2.0 through 3.2.4. Users are recommended to upgrade to the latest version, which fixes the issue.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Software Foundation Apache Dubbo

    From 3.1.0 · through 3.1.10; From 3.2.0 · through 3.2.4

  • org.apache.dubbo:dubboMaven

    From 3.1.0 · fixed in 3.1.11

  • org.apache.dubbo:dubboMaven

    From 3.2.0 · fixed in 3.2.5

References 2

lists.apache.org

openwall.com