Skip to main content
← All vulnerabilities
CVE-2023-29216GHSA-RRHF-32RQ-F28H

Apache Linkis DatasourceManager module has a deserialization command execution

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.3.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker uses the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Linkis

    through 1.3.1

  • org.apache.linkis:linkis-datasourceMaven

    fixed in 1.3.2

References 2

lists.apache.org

openwall.com