Skip to main content
← All vulnerabilities
CVE-2023-28836GHSA-5286-F2RF-35C2PYSEC-2023-55

Wagtail vulnerable to stored Cross-site Scripting attack via ModelAdmin views

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.1.1, 4.2.2, 4.1.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Wagtail is an open source content management system built on Django. Starting in version 1.5 and prior to versions 4.1.4 and 4.2.2, a stored cross-site scripting (XSS) vulnerability exists on ModelAdmin views within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft pages and documents that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, and only affects sites with ModelAdmin enabled. For page, the vulnerability is in the "Choose a parent page" ModelAdmin view (`ChooseParentView`), available when managing pages via ModelAdmin. For documents, the vulnerability is in the ModelAdmin Inspect view (`InspectView`) when displaying document fields. Patched versions have been released as Wagtail 4.1.4 and Wagtail 4.2.2. Site owners who are unable to upgrade to the new versions can disable or override the corresponding functionality.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • wagtail wagtail

    From 1.5; From 4.1.1 · fixed in 4.1.1; From 4.2; From 4.2.2 · fixed in 4.2.2

  • wagtailPyPI

    From 1.5 · fixed in 4.1.4

  • wagtailPyPI

    From 4.2 · fixed in 4.2.2

  • wagtailPyPI

    From 1.5 · fixed in 4.1.4; From 4.2 · fixed in 4.2.2

References 8

GitHub · wagtail/wagtail

docs.wagtail.org