Skip to main content
← All vulnerabilities
CVE-2023-28101

Flatpak metadata with ANSI control codes can cause misleading terminal output

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.10.8, 1.12.8, 1.14.4, 1.15.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Flatpak is a system for building, distributing, and running sandboxed desktop applications on Linux. In versions prior to 1.10.8, 1.12.8, 1.14.4, and 1.15.4, if an attacker publishes a Flatpak app with elevated permissions, they can hide those permissions from users of the `flatpak(1)` command-line interface by setting other permissions to crafted values that contain non-printable control characters such as `ESC`. A fix is available in versions 1.10.8, 1.12.8, 1.14.4, and 1.15.4. As a workaround, use a GUI like GNOME Software rather than the command-line interface, or only install apps whose maintainers you trust.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • flatpak flatpak

    fixed in 1.10.8; From 1.12.0 · fixed in 1.12.8; From 1.14.0 · fixed in 1.14.4; From 1.15.0 · fixed in 1.15.4

References 5

GitHub · flatpak/flatpak

security.gentoo.org