Skip to main content
← All vulnerabilities
CVE-2023-28098

OpenSIPS has vulnerability in the Digest Authentication Parser

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.1.7, 3.2.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, a specially crafted Authorization header causes OpenSIPS to crash or behave in an unexpected way due to a bug in the function `parse_param_name()` . This issue was discovered while performing coverage guided fuzzing of the function parse_msg. The AddressSanitizer identified that the issue occurred in the function `q_memchr()` which is being called by the function `parse_param_name()`. This issue may cause erratic program behaviour or a server crash. It affects configurations containing functions that make use of the affected code, such as the function `www_authorize()` . Versions 3.1.7 and 3.2.4 contain a fix.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • OpenSIPS opensips

    fixed in 3.1.7; From 3.2.0 · fixed in 3.2.4

References 3

GitHub · OpenSIPS/opensips

opensips.org