Skip to main content
← All vulnerabilities
CVE-2023-28097

OpenSIPS has vulnerability in the Content-Length Parser

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.1.9, 3.2.6
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.9 and 3.2.6, a malformed SIP message containing a large Content-Length value and a specially crafted Request-URI causes a segmentation fault in OpenSIPS. This issue occurs when a large amount of shared memory using the `-m` flag was allocated to OpenSIPS, such as 10 GB of RAM. On the test system, this issue occurred when shared memory was set to `2362` or higher. This issue is fixed in versions 3.1.9 and 3.2.6. The only workaround is to guarantee that the Content-Length value of input messages is never larger than `2147483647`.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • OpenSIPS opensips

    fixed in 3.1.9; From 3.2.0 · fixed in 3.2.6

References 3

GitHub · OpenSIPS/opensips

opensips.org