Skip to main content
← All vulnerabilities
CVE-2023-27898GHSA-J664-QHH4-HPF8BIT-JENKINS-2023-27898

Jenkins 2.270 through 2.393 (both inclusive), LTS 2.277.1 through 2.375.3 (both inclusive) does not escape the Jenkins version a plugin depe

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.375.4, 2.387.1, 2.394
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Jenkins 2.270 through 2.393 (both inclusive), LTS 2.277.1 through 2.375.3 (both inclusive) does not escape the Jenkins version a plugin depends on when rendering the error message stating its incompatibility with the current version of Jenkins, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide plugins to the configured update sites and have this message shown by Jenkins instances.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Jenkins Project Jenkins

    From 2.270 · fixed in 2.375.4; From 2.376 · fixed in 2.387.1; From 2.388 · fixed in 2.394

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.376 · fixed in 2.394

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.375.4

References 1

jenkins.io