Skip to main content
← All vulnerabilities
CVE-2023-27599

OpenSIPS has vulnerability in the parse_to_param() function

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.1.7, 3.2.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, when the function `append_hf` handles a SIP message with a malformed To header, a call to the function `abort()` is performed, resulting in a crash. This is due to the following check in `data_lump.c:399` in the function `anchor_lump`. An attacker abusing this vulnerability will crash OpenSIPS leading to Denial of Service. It affects configurations containing functions that make use of the affected code, such as the function `append_hf`. This issue has been fixed in versions 3.1.7 and 3.2.4.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • OpenSIPS opensips

    fixed in 3.1.7; From 3.2.0 · fixed in 3.2.4

References 3

GitHub · OpenSIPS/opensips

opensips.org