Skip to main content
← All vulnerabilities
CVE-2023-27597

OpenSIPS has vulnerability in the parse_uri() function

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.1.8, 3.2.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, when a specially crafted SIP message is processed by the function `rewrite_ruri`, a crash occurs due to a segmentation fault. This issue causes the server to crash. It affects configurations containing functions that make use of the affected code, such as the function `setport`. This issue has been fixed in version 3.1.8 and 3.2.5.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • OpenSIPS opensips

    fixed in 3.1.8; From 3.2.0 · fixed in 3.2.5

References 2

GitHub · OpenSIPS/opensips