WordPress Core < 6.2.1 - Directory Traversal
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.1.38, 4.2.35, 4.3.31, 4.4.30, 4.5.29, and 17 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 on Exploit-DB, 1 proof of concept on GitHub, 1 Nuclei template
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
WordPress Core is vulnerable to Directory Traversal in versions up to, and including, 6.2, via the ‘wp_lang’ parameter. This allows unauthenticated attackers to access and load arbitrary translation files. In cases where an attacker is able to upload a crafted translation file onto the site, such as via an upload form, this could be also used to perform a Cross-Site Scripting attack.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Public exploit on Exploit-DB
EDB-52274
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- WordPress Foundation WordPress
fixed in 4.1.38; From 4.2 · fixed in 4.2.35; From 4.3 · fixed in 4.3.31; From 4.4 · fixed in 4.4.30; From 4.5 · fixed in 4.5.29; From 4.6 · fixed in 4.6.26; From 4.7 · fixed in 4.7.26; From 4.8 · fixed in 4.8.22; From 4.9 · fixed in 4.9.23; From 5.0 · fixed in 5.0.19; From 5.1 · fixed in 5.1.16; From 5.2 · fixed in 5.2.18; From 5.3 · fixed in 5.3.15; From 5.4 · fixed in 5.4.13; From 5.5 · fixed in 5.5.12; From 5.6 · fixed in 5.6.11; From 5.7 · fixed in 5.7.9; From 5.8 · fixed in 5.8.7; From 5.9 · fixed in 5.9.6; From 6.0 · fixed in 6.0.4; From 6.1 · fixed in 6.1.2; From 6.2 · fixed in 6.2.1