Skip to main content
← All vulnerabilities
CVE-2023-26464GHSA-VP98-W2P3-MV35

Apache Log4j 1.x (EOL) allows DoS in Chainsaw and SocketAppender

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
Fix
Fixed in 2, 2.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

** UNSUPPORTED WHEN ASSIGNED ** When using the Chainsaw or SocketAppender components with Log4j 1.x on JRE less than 1.7, an attacker that manages to cause a logging entry involving a specially-crafted (ie, deeply nested) hashmap or hashtable (depending on which logging component is in use) to be processed could exhaust the available memory in the virtual machine and achieve Denial of Service when the object is deserialized. This issue affects Apache Log4j before 2. Affected users are recommended to update to Log4j 2.x. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Log4j

    From 1.0.4 · fixed in 2

  • org.apache.logging.log4j:log4j-coreMaven

    From 1.0.4 · fixed in 2.0

  • log4j:log4jMaven

    From 1.0.4 · fixed in 2.0

References 2

lists.apache.org

security.netapp.com